First visit? Checkout the "welcome" post

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
start a store
(05-16-2017, 07:00 PM)bananajoe Wrote: so after some time iam back. In the mean time, i changed the OS of my banana to Armbian. Lubuntu was running Ok as long as i used the original lemaker 14.4. 14.4 is no longer supported and an upgrade to 16.4 resulted in a desaster. some components didnt work anymore and the original ditribution upgrades dont support the lemaker stuff at all.

After some search i ended up with Armbian, an arm special debian package for these small PIs, like raspberryPi, orangePi, bananaPi.

So far the OS is running quite good, but the installation of the bazaar still doesnt work. I have problems with permissions of the installation, serveral python modules are not installed, the version of pip is not the right one,....

Too much for me to cope with. But i dont give up.

Maybe i start a projekt on xbtfreelancer to find somone to give me some halt with python modules.

does anyone here in the group know a way to contact the developer team of openbazzar?
What they cll forum on ist their blog, but i can not ask questions there.
On github i dont find a way to ask for some help.

I think it should be easy for the dev-guys to explain the installation to me.
At the moment i just follow the instructions from github and up in a fix everytime.

Hi Bananjoe! You may want to try to ask the community who is in our Reddit & Slack, there are more people, including our developers, there:
I think Abanob can fix this, 

Quote:abanob [3:08 PM] 
So its clear now.
You can remove any other python version and all its staff.
Then install python 2.7.9
Then go download openbazzar files and pip the requirements.txt file it will install all needed versions of pip and wheel and others type it may need.

If that isn't enough, let me know and you can chat with him and maybe he can do it with you using TeamViewer or whatever?
Free Trade for Africa (and other places too...)

This might solve it...
I sent Abanob this  install instruction I had been using,
Quote:That pdf is awesome.. i checked it .. its already doing what i was going to do..also that is installing all you need in one easy step

But the only problem..that its installing the latest version of python and you need to install python 2.7.9

You have to compile that version yourself. It should be a simple configure, make, make install. Download the 2.7.9 version, unpack it and run:

sudo make install

After that you can remove python-dev from the and do the whole code so it will be ok

Here is the link of the version  2.7.9
Just download source code tarball and extract it and compile like i said up.

Hope that helps!
thank you for the effort.
I will have to work a little bit for living, but i will get back to it to the end of the week.
Then i will try it.

Up to now, i never did some compiling myself. So it might be, that i have some questions about that too.

read you later.....
Hi again, i am back.

Within the next days i will start again on my store project.

My first goal was to install python Version 2.7.9

> Here is the link of the version 2.7.9

Ok, that worked out fine - but with no help to me whatsoever......

After the successfull installation oft python 2.7.9 the system reported 36 broken packages resulting from this python installation.
After sudo update/upgrade everything was allright again. Python 2.7.11-1 is installed now and this keeps the system running and it seems that this python version is not interfering with my bazaar installation ( as far as i can see for this moment).

So as a result it is not the version 2.7.9 needed, but the latest according to the linux dsitri but not older than 2.7.9.

I had a lot to learn and try but now at least this problem seems to be solved. Gracias

After this i made myself up to installing the bazaar script.

> This might solve it...
> I sent Abanob this install instruction I had been using,
> [url=][/url]

I downloaded the script an read it before - goog idea! As i could read this script is for *buntu 15.10 (codename vivid).

the current LTS distri is 16.04. the mentioned script is taken from the githup channel of DrWasho from Australia. On his githup page we can find all kinds of installation scripts for bazaar.

I also read the script for 16.04 and decided to install the 16.04 script. Sorry - not install the script, rather use it line by line.

It starts with sudo apt get update / upgrade to set the system to current state and so on.

I took every line and executed each line one after the other.

Now its getting interesting.

It seems to be important to install not only line by line but also to install some commands before installing other commands.

So eventually i got the main line with all different installations installed. Fine so far.

> sudo apt-get install -y git build-essential libssl-dev libffi-dev python-dev openssl python-pip libzmq3-dev libsodium-dev
> autoconf libzmq-dev pkg-config libtool

(here the order seems to be significant) I got it after some tries.

> (cd /$HOME/; sudo git clone

This line seems to be the same on every system and i got it going fine. Exept from one thing,....

> The directory '/home/<user>/.cache/pip' or its parent directory is not owned by the current user and caching wheels has
> been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.

Here we seem to have a major problem. The whole directory -OpenBazaar-Server- is owned by root but situated in the User/home folder. I think some installations, copies, commands are not executed properly, because the >user< has not the permissions on this directory that are needed.
I may be wrong, but it is worth a look into it.

Lets got to the last line in the script.

> (cd /$HOME/OpenBazaar-Server; sudo pip install -r requirements.txt)

After some time of installation i get the following output

> Complete output from command python egg_info:
> Traceback (most recent call last):
> File "<string>", line 1, in <module>
> ImportError: No module named setuptools
> ----------------------------------------
> Command "python egg_info" failed with error code 1 in /tmp/pip-build-q5bYe3/cryptography/

Finally i have two problems with my installation,

first there is this owner problem with the OpenBazaar-Server directory.
Maybe it is nessesary to change the owner during installation (but how?)

second the missing module setuptools. I have no idea for that.

This was a rather long text, but hopefully it helps to find the faults in executing this script.
Sorry for the delay, I put the question in the wrong chat initially,
The 2 problems of the person who is installing the openbazzar..
The first problem:
As i see the script ask you to create a user and ita own this folder.. you can easyily manage to addusr and do the ownership of the folder to him.

Second problem:
Here is the command line for install setuptools but please firstly check if openbazzar needing a specific version of it.
sudo apt-get install python-pip python-setuptools python-wheel

Users browsing this thread: 1 Guest(s)